After I did an upgrade gimp was automatically removed and then I couldn’t install it.
Every time I tried it showed me the error below..
It took me a while to find where is the problem and fix it, so here is what I did.
This is the error that showed when I tried to install gimp:
$ sudo apt-get install gimp Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: gimp : Depends: libglib2.0-0 (>= 2.31.2) but 2.30.0-0ubuntu4 is to be installed E: Unable to correct problems, you have held broken packages.
Then I did a:
$ apt-cache policy gimp gimp: Installed: (none) Candidate: 2.7.5-2012020901~oo Version table: 2.7.5-2012020901~oo 0 500 http://ppa.launchpad.net/matthaeus123/mrw-gimp-svn/ubuntu/ oneiric/main amd64 Packages 2.7.4-2011102201~oo 0 100 /var/lib/dpkg/status 2.6.11-2ubuntu4 0 500 http://al.archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
After that I saw that the problem stands at my PPA, (I actually added that months ago just to test some new features, I dont really remember)
What I did is, I removed my PPA from matthaeus123
(I just edited the files and commented the lines) Continue reading “gimp : Depends: libglib2.0-0 (>= 2.31.2) but 2.30.0-0ubuntu4 is to be installed”